Seamless3d 3.005 Ready for download

Main Forum

  Threads Index  

This is an important update as this is the first version where Seamless3d III has been worked through for an animation tutorial. This tutorial: Creating an Animated Character Step by Step Using Free Open Source Software

https://youtu.be/zV2_UYg8v5g

starts with modelling the character from a box and ends with a fully animated jumping character.

The new version supports a number of new features such as being able to add a nurbs line by dragging to draw the line.
See the Drawing NURBS Lines tutorial
http://www.seamless3d.com/drawing-nurbs-lines/index.html
for more info.

The new version also supports the use of a Graphics Pen & Touch Tablet.
See the tutorial: Using a Graphics Pen & Touch Tablet
http://www.seamless3d.com/graphics-pen-touch-tablet/index.html

For more info on the new version see:
http://www.seamless3d.com/download/3.000.html#_3.005


Best wishes Happy

thyme - 2017-08-20 22:16:00

Your Response:          


Hi Thyme,

Congrats for the new version Happy

Installed version 3.005 but gives an error about directX 8.1 or up not installed and stops.
The thing is that I Have directX 12 installed and even reinstalled; also checked with dxdiag and it is OK but seamless keeps asking for it and stops.
Is there another possible reason for this you know about?

Thanks

Vitor Cardoso (aka vcard) - 2017-08-26 08:58:05 in reply to thyme 2017-08-20 22:16:00

Your Response:          


I ran seamless on Windows 10, but I didn't install or update directx.
AFAIK, Windows from Vista to 10 includes dx9, wich is the latest compatible runtime for dx 7, 8 and so.
From dx10 until now, despite a discrete backward compatibility, there's almost no support for APIs as ancient as directx 8.
You could try uninstalling dx12 or install on its side the 9.0x runtime.

By the way, didn't you receive the popup asking to install needed functionality at program launch?

Powerful - 2017-08-26 10:44:31 in reply to Vitor Cardoso (aka vcard) 2017-08-26 08:58:05

Your Response:          


Hi vcard Happy, very sorry to hear seamless wont run for you. I have windows 10 with DirectX 12 and I don't have a problem but after seeing your post and some searching, I found here:

http://www.tomshardware.com/forum/id-2756506/directx-games-work-windows.html

some have problems running games written for DirectX 9 and what can be done to fix it.
Hopefully this remedy also applies to programs that use DirectX 8.1
You could instead wait until I update seamless to use DirectX 12 but I don't know when this will be. Sadly I have accepted there is not enough time left in the year to do all the things I have already planned for it but I will look further into seeing what's involved to make the update.

Thanks much for your feedback.

thyme - 2017-08-26 13:05:31 in reply to Vitor Cardoso (aka vcard) 2017-08-26 08:58:05

Your Response:          


It seems Mikerman had the same problem you had vcard. After seeing his screen shot of the message I realised that was a message I added when many at the time had a lower version of DirctX but this would no longer be an issue and it looks like this code that checks for DX 8.1 is only causing problems so I have removed it for this version you can download from here: http://www.seamless3d.com/download/early.html
Feeling optimistic it will work now Happy

thyme - 2017-09-06 12:53:44 in reply to Vitor Cardoso (aka vcard) 2017-08-26 08:58:05

Your Response:          


The new upload works for Mikerman so that seems all it was, so glad about that Happy The version he tested has now become the current online version (2.006)

thyme - 2017-09-09 14:36:20 in reply to Vitor Cardoso (aka vcard) 2017-08-26 08:58:05

Your Response:          


 

Main Forum

 


[3d Modelling Software] [Tutorials] [Forum] [Features] [Download] [Gallery] [FAQ] [Worlds] [Avatars] [Links] [Thyme]

v:1